Pulog

Spring Boot v2.3 から javax.validation.* は別途依存追加が必要

Spring Boot 2.3 Release Notes · spring-projects/spring-boot Wiki に書かれている通りなのですが、 @Max@NotBlank アノテーション等のフォームバリデーションのライブラリが Spring Boot の web-starter から除かれたようです。

別途 validation-starter を追加してあげる必要があります。

Gradleを利用しているのであれば、以下のようにbuild.gradleへ追記してあげればOK。

dependencies {
  // 中略...
  implementation 'org.springframework.boot:spring-boot-starter-validation'
}

Sping Boot v2.2以下からv2.3へアップデートする際には注意が必要ですね。